@raafey i assume you using our launcher with a different client,
which is fine. it should work anyways,
But our launcher has an additional file in the cfg folder to keep track of the version,
If the file does not exist it will ask you for the protocol version of the client.

Our current client has the version "2306" That you need to enter in that field .
If your client has a different version, put in the one from your client.
then it should work fine.

But in any case. most times "auth failed" is not related to the launcher or version. try maybe to restart steam ? .